“Exception occurred in install precheck phase” while patching to vCenter Server 7.0 U2 and newer

VMware released the KB83145 adressing this issue. When updating vCenter Service appliance through management UI you will get this error message :

The error is a known issue and has not been resolved yet!

Please follow the below steps to apply the workaround:

Note: Follow the below steps only when the patch is failed before RPM installation.

  1. Take a snapshot of the VC, login into putty/ssh session to VC
  2. Download the script KB_83145_PatchCleanupScript.sh from the attachment section in the KB to the root folder of the VC.
  3. Provide executable permissions to the script, run the command:

chmod +x KB_83145_PatchCleanupScript.sh

  1. Run the script using the command:

./KB_83145_PatchCleanupScript.sh

  1. Once the script execution is complete, Go to VAMI page using url https://<VC_IP or VC_FQDN>:5480 enter the root credentials.
  1. Click on Update > Check Updates, select the target update from the list.
    • Note: Wait for the updates to load, do not click on refresh.
  2. Proceed with upgrade by clicking on  “Stage” or “Stage and Install”.

The script and most recent information can be found at VMware knowledge base: https://kb.vmware.com/s/article/83145

You may also like...

Leave a Reply

Your email address will not be published.